{"answers":{"affected":"3 open source packages ship an affected version, including lemur.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55164 exists.","fix":"Upgrade lemur to 1.9.2 or later.","what":"CVE-2026-55164 is a medium-severity vulnerability in Netflix lemur, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55164 and fix it if it is affected.\n\nWhat it is: CVE-2026-55164 is a medium-severity vulnerability in Netflix lemur, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55164 exists.\n\nAffected packages and fixed versions:\n- lemur (PyPI): affected all versions; fixed in 1.9.2\n- lemur (PyPI): affected all versions; fixed in 1.9.2\n- lemur (PyPI): affected all versions; fixed in 1.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55164/ (Markdown: https://insights.sbomify.com/CVE-2026-55164/index.md)","id":"CVE-2026-55164","markdown":"https://insights.sbomify.com/CVE-2026-55164/index.md","name":"CVE-2026-55164","record":{"aliases":["GHSA-q437-g7fv-2jvv","PYSEC-2026-2587"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TLS certificate management","requires_auth":"high_privilege","summary":"Administrators can store user passwords in plaintext, exposing credentials to database compromises and preventing normal authentication.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-256","name":"Plaintext Storage of a Password"}],"description":"Lemur manages TLS certificate creation. Prior to 1.9.2, lemur.users.service.update assigned a replacement password directly to users.password, while lemur/users/models.py registered User.hash_password only for the before_insert event. Because no before_update listener ran, administrator-initiated password changes through PUT /api/1/users/ were committed as plaintext. The affected user could no longer authenticate normally because bcrypt verification received an unhashed value. A database, backup, replica, query-log, or administrative read compromise exposed immediately usable credentials without offline cracking. The fix registers hashing for before_update and avoids rehashing values that already have a bcrypt prefix. This issue is fixed in version 1.9.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lemur: Plaintext password storage in Lemur user-update path","id":"CVE-2026-55164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Lemur: JWT verifier honors attacker-supplied alg, enabling ATO","id":"CVE-2026-55165"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":null,"source":"GHSA-q437-g7fv-2jvv"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":"pkg:pypi/lemur","source":"GHSA-q437-g7fv-2jvv"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"lemur","purl":"pkg:pypi/lemur","source":"PYSEC-2026-2587"}],"prev":{"headline":"Lemur: Privilege escalation via PUT /api/1/roles/\u003cid\u003e — non-admin role members can rewrite role membership","id":"CVE-2026-55163"},"products":["lemur"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["Netflix"]},"summary":"Administrators can store user passwords in plaintext, exposing credentials to database compromises and preventing normal authentication.","url":"https://insights.sbomify.com/CVE-2026-55164/"}