# CVE-2026-55164: Lemur: Plaintext password storage in Lemur user-update path

> Administrators can store user passwords in plaintext, exposing credentials to database compromises and preventing normal authentication.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-q437-g7fv-2jvv, PYSEC-2026-2587

## What is CVE-2026-55164?

CVE-2026-55164 is a medium-severity vulnerability in Netflix lemur, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.2, lemur.users.service.update assigned a replacement password directly to users.password, while lemur/users/models.py registered User.hash_password only for the before_insert event. Because no before_update listener ran, administrator-initiated password changes through PUT /api/1/users/ were committed as plaintext. The affected user could no longer authenticate normally because bcrypt verification received an unhashed value. A database, backup, replica, query-log, or administrative read compromise exposed immediately usable credentials without offline cracking. The fix registers hashing for before_update and avoids rehashing values that already have a bcrypt prefix. This issue is fixed in version 1.9.2.

Weakness: CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2026-55164?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |

## How do I fix CVE-2026-55164?

Upgrade lemur to 1.9.2 or later.

## Is CVE-2026-55164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55164 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55164 and fix it if it is affected.

What it is: CVE-2026-55164 is a medium-severity vulnerability in Netflix lemur, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55164 exists.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55164/ (Markdown: https://insights.sbomify.com/CVE-2026-55164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55164
- OSV: https://osv.dev/vulnerability/CVE-2026-55164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55164/
Summaries are generated and may contain mistakes; the official description above is the record.
