# CVE-2026-55166: Lemur: ACME SSRF + creator-equality IDOR lead to AWS IAM/PKI compromise

> Authenticated users can exploit SSRF in ACME URL handling to steal cloud credentials and access private keys via IDOR.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-v2wp-frmc-5q3v, PYSEC-2026-384

## What is CVE-2026-55166?

CVE-2026-55166 is a critical server-side request forgery vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.2, authenticated users could influence an ACME authority acme_url without an effective server-side destination restriction and trigger AcmeHandler.setup_acme_client to make backend requests. An attacker could target cloud instance metadata or internal services from Lemur network context, potentially obtaining credentials available to the host. The advisory also identifies creator-equality authorization behavior that could preserve access to certificate key material after ownership or role changes, with insufficient export_private_key audit context to distinguish that access path. Together, the acme_url server-side request forgery and authorization weakness could expose cloud credentials and long-lived PKI private-key access. The fix adds ACME_DIRECTORY_HOST_ALLOWLIST validation and enriches key-export audit events with creator and current-owner context. This issue is fixed in version 1.9.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-55166?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |

## How do I fix CVE-2026-55166?

Upgrade lemur to 1.9.2 or later.

## Is CVE-2026-55166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55166 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55166 and fix it if it is affected.

What it is: CVE-2026-55166 is a critical server-side request forgery vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55166 exists.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55166/ (Markdown: https://insights.sbomify.com/CVE-2026-55166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55166
- OSV: https://osv.dev/vulnerability/CVE-2026-55166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55166/
Summaries are generated and may contain mistakes; the official description above is the record.
