# CVE-2026-55170: OpenFGA MySQL backend: case-insensitive collation on identifier columns causes incorrect authorization decisions

> OpenFGA with MySQL may incorrectly treat case-distinct user identifiers as equivalent, allowing unauthorized access to protected resources.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** CLEANSTART-2026-GZ01306, CLEANSTART-2026-IY19644, CLEANSTART-2026-YO15719, CLEANSTART-2026-ZO68951, ECHO-d475-f680-bede, GHSA-cf98-j28v-49v6, GO-2026-5322, MINI-22wv-28c8-95p6, MINI-2q63-vv2c-g7wc, MINI-3gmf-9qp8-qr8f, MINI-44jv-4qx5-jxq7, MINI-9cjh-2w48-2rmj, MINI-cxf4-vc26-2h3c, MINI-f253-hx56-phv7, MINI-f6qx-fx4x-p57j, MINI-fm55-4q8c-72v8, MINI-jvc5-qr6w-c5rc, MINI-p4ch-vcr2-5346, MINI-ph89-gj23-3xq7, MINI-pjjp-pmvr-6xx9, MINI-q554-xww2-8xrj, MINI-qm95-378v-2fpp, MINI-vqc6-mcqm-q429, MINI-xrqm-359x-q87x, MINI-xv97-g7xp-gw4x

## What is CVE-2026-55170?

CVE-2026-55170 is a low-severity authentication bypass vulnerability in openfga, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, when MySQL is being used as the datastore and authorization decisions rely on case-sensitive user strings, the tuple, changelog, and authorization_model identifier columns can compare case-distinct values such as user:Alice and user:alice as equivalent, causing two distinct check requests to return the same response. This issue is fixed in 1.18.0.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-55170?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.0 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-55170?

Upgrade github.com/openfga/openfga to 1.18.0 or later.

## Is CVE-2026-55170 being exploited?

There is no known exploitation of CVE-2026-55170 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55170 and fix it if it is affected.

What it is: CVE-2026-55170 is a low-severity authentication bypass vulnerability in openfga, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55170 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55170/ (Markdown: https://insights.sbomify.com/CVE-2026-55170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55170
- OSV: https://osv.dev/vulnerability/CVE-2026-55170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55170/
Summaries are generated and may contain mistakes; the official description above is the record.
