# CVE-2026-55174: UltrafastSecp256k1: ECDSA adaptor verification accepts non-adaptable pre-signatures due to missing DLEQ binding

> Attackers can forge ECDSA adaptor pre-signatures due to missing cryptographic binding, bypassing verification in the UltrafastSecp256k1 library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-c7q2-gv3g-rgxm

## What is CVE-2026-55174?

CVE-2026-55174 is a medium-severity vulnerability in shrec UltrafastSecp256k1, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

UltrafastSecp256k1 is a high-performance, multi-backend secp256k1 engine with reproducible audit evidence, compatibility shims, and profile-based review scopes. Prior to version 4.2.0, UltrafastSecp256k1's ECDSA adaptor pre-signature verification accepts forged adaptor pre-signatures whose "r" value is not cryptographically bound to the adaptor point "T". This issue has been patched in version 4.2.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-55174?


## How do I fix CVE-2026-55174?

No fix has been published for CVE-2026-55174 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55174 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55174 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55174 and fix it if it is affected.

What it is: CVE-2026-55174 is a medium-severity vulnerability in shrec UltrafastSecp256k1, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55174 exists.

Affected product: shrec UltrafastSecp256k1. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55174/ (Markdown: https://insights.sbomify.com/CVE-2026-55174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55174
- OSV: https://osv.dev/vulnerability/CVE-2026-55174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55174/
Summaries are generated and may contain mistakes; the official description above is the record.
