CVE-2026-55175 Spinnaker: Improper yaml processing on kustomize bake operations
Attackers can achieve remote code execution on rosco pods via unsafe YAML tag processing during Kustomize bake operations in Spinnaker.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55175?
CVE-2026-55175 is a high-severity unsafe deserialization vulnerability in spinnaker, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to versions 2026.1.1, 2026.0.3, 2025.4.4, and 2025.3.4 on their respective release lines, Kustomize bake operations allow unsafe YAML tag processing in rosco manifests. This can lead to remote code execution on rosco pods when performing Kustomize bakes. This issue is fixed in versions 2026.1.1, 2026.0.3, 2025.4.4, and 2025.3.4.
Weakness: CWE-502
Which versions are affected by CVE-2026-55175?
8 open source packages ship an affected version, including io.spinnaker.rosco:rosco-manifests. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.spinnaker.rosco:rosco-manifests Maven | All versions | 2025.3.4 |
io.spinnaker.rosco:rosco-manifests Maven | All versions | 2025.3.4 |
io.spinnaker.rosco:rosco-manifests Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.rosco:rosco-manifests Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.rosco:rosco-manifests Maven | From 2026.0.0 | 2026.0.3 |
io.spinnaker.rosco:rosco-manifests Maven | From 2026.0.0 | 2026.0.3 |
2 more packages
io.spinnaker.rosco:rosco-manifests Maven | From 2026.1.0 | 2026.1.1 |
io.spinnaker.rosco:rosco-manifests Maven | From 2026.1.0 | 2026.1.1 |
Products include Linuxfoundation Spinnaker.
How do I fix CVE-2026-55175?
Upgrade io.spinnaker.rosco:rosco-manifests to a fixed version for your release line: 2025.3.4, 2025.4.4, 2026.0.3 or 2026.1.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-55175 being exploited?
There is no known exploitation of CVE-2026-55175 in the wild and no public exploit code.
Other vulnerabilities in spinnaker
- CVE-2026-32604 Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths
- CVE-2026-32613 Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling
- CVE-2021-43832 Improper Access Control in spinnaker
- CVE-2026-44795 Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
- CVE-2020-9301 Code injection in Netflix Spinnaker
Sources
Also known as GHSA-p68j-q7hf-3qcp.