# CVE-2026-55175: Spinnaker: Improper yaml processing on kustomize bake operations

> Attackers can achieve remote code execution on rosco pods via unsafe YAML tag processing during Kustomize bake operations in Spinnaker.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-p68j-q7hf-3qcp

## What is CVE-2026-55175?

CVE-2026-55175 is a high-severity unsafe deserialization vulnerability in spinnaker, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to versions 2026.1.1, 2026.0.3, 2025.4.4, and 2025.3.4 on their respective release lines, Kustomize bake operations allow unsafe YAML tag processing in rosco manifests. This can lead to remote code execution on rosco pods when performing Kustomize bakes. This issue is fixed in versions 2026.1.1, 2026.0.3, 2025.4.4, and 2025.3.4.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-55175?

8 open source packages ship an affected version, including io.spinnaker.rosco:rosco-manifests. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.spinnaker.rosco:rosco-manifests` | Maven | All versions | 2025.3.4 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | All versions | 2025.3.4 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2025.4.0 | 2025.4.4 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2025.4.0 | 2025.4.4 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2026.0.0 | 2026.0.3 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2026.0.0 | 2026.0.3 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2026.1.0 | 2026.1.1 |
| `io.spinnaker.rosco:rosco-manifests` | Maven | From 2026.1.0 | 2026.1.1 |

Products: Linuxfoundation Spinnaker.

## How do I fix CVE-2026-55175?

Upgrade io.spinnaker.rosco:rosco-manifests to a fixed version for your release line: 2025.3.4, 2025.4.4, 2026.0.3 or 2026.1.1.

## Is CVE-2026-55175 being exploited?

There is no known exploitation of CVE-2026-55175 in the wild and no public exploit code.

## Other vulnerabilities in spinnaker

- [CVE-2026-32604](https://insights.sbomify.com/CVE-2026-32604/): Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths (critical 10.0)
- [CVE-2026-32613](https://insights.sbomify.com/CVE-2026-32613/): Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling (critical 10.0)
- [CVE-2021-43832](https://insights.sbomify.com/CVE-2021-43832/): Improper Access Control in spinnaker (critical 10.0)
- [CVE-2026-44795](https://insights.sbomify.com/CVE-2026-44795/): Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types (high 8.8)
- [CVE-2020-9301](https://insights.sbomify.com/CVE-2020-9301/): Code injection in Netflix Spinnaker (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55175 and fix it if it is affected.

What it is: CVE-2026-55175 is a high-severity unsafe deserialization vulnerability in spinnaker, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55175 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.spinnaker.rosco:rosco-manifests (Maven): affected all versions; fixed in 2025.3.4
- io.spinnaker.rosco:rosco-manifests (Maven): affected all versions; fixed in 2025.3.4
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2025.4.0; fixed in 2025.4.4
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2025.4.0; fixed in 2025.4.4
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2026.0.0; fixed in 2026.0.3
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2026.0.0; fixed in 2026.0.3
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2026.1.0; fixed in 2026.1.1
- io.spinnaker.rosco:rosco-manifests (Maven): affected from 2026.1.0; fixed in 2026.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55175/ (Markdown: https://insights.sbomify.com/CVE-2026-55175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55175
- OSV: https://osv.dev/vulnerability/CVE-2026-55175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55175/
Summaries are generated and may contain mistakes; the official description above is the record.
