# CVE-2026-55180: pnpm: Repository config can expand victim environment secrets into registry requests before scripts run

> A malicious repository can leak victim environment secrets to an attacker-controlled registry during dependency resolution in pnpm.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-3qhv-2rgh-x77r, MINI-hcf4-cm48-ccpg, ROOT-APP-NPM-CVE-2026-55180

## What is CVE-2026-55180?

CVE-2026-55180 is a medium-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm and pacquet expanded ${ENV_VAR} placeholders from repository-controlled .npmrc and pnpm-workspace.yaml into registry request destinations and registry credentials. A malicious repository could cause dependency resolution to send victim environment secrets to an attacker-selected registry before lifecycle scripts run. This vulnerability is fixed in 10.34.2 and 11.5.3.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55180?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-55180?

Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.

## Is CVE-2026-55180 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55180 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55180 and fix it if it is affected.

What it is: CVE-2026-55180 is a medium-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55180 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55180/ (Markdown: https://insights.sbomify.com/CVE-2026-55180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55180
- OSV: https://osv.dev/vulnerability/CVE-2026-55180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55180/
Summaries are generated and may contain mistakes; the official description above is the record.
