# CVE-2026-55182: LibreNMS: Remote Code Execution by Signal Alert Transportation Module

> An authenticated administrator can execute arbitrary OS commands on LibreNMS hosts via command injection in the Signal alert transport module.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-c9fv-cgmm-2wg7

## What is CVE-2026-55182?

CVE-2026-55182 is a high-severity command injection vulnerability in librenms, published on 26 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-55182?

2 open source packages ship an affected version, including librenms/librenms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | From 21.6.0 | 26.5.0 |
| `librenms/librenms` | Packagist | From 21.6.0 | 26.5.0 |

## How do I fix CVE-2026-55182?

Upgrade librenms/librenms to 26.5.0 or later.

## Is CVE-2026-55182 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55182 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55182 and fix it if it is affected.

What it is: CVE-2026-55182 is a high-severity command injection vulnerability in librenms, published on 26 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55182 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected from 21.6.0; fixed in 26.5.0
- librenms/librenms (Packagist): affected from 21.6.0; fixed in 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55182/ (Markdown: https://insights.sbomify.com/CVE-2026-55182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55182
- OSV: https://osv.dev/vulnerability/CVE-2026-55182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55182/
Summaries are generated and may contain mistakes; the official description above is the record.
