# CVE-2026-55184: EspoCRM: Stored XSS in wysiwyg template fields if CSP is disabled

> An attacker with template edit permissions can inject malicious HTML that executes in other users' browsers if CSP is disabled, leading to session hijacking.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-x5p5-8mxj-9wv6

## What is CVE-2026-55184?

CVE-2026-55184 is a low-severity cross-site scripting vulnerability in espocrm, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

EspoCRM is an open source customer relationship management application. Prior to 9.3.9, a user with Email Template or PDF Template edit permission can store crafted HTML that bypasses moderateSanitizeHtml(). When another user opens the template in edit mode and clientCspDisabled is true, the stored payload executes and can hijack the user's session. This issue is fixed in version 9.3.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55184?


## How do I fix CVE-2026-55184?

No fix has been published for CVE-2026-55184 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55184 being exploited?

There is no known exploitation of CVE-2026-55184 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55184 and fix it if it is affected.

What it is: CVE-2026-55184 is a low-severity cross-site scripting vulnerability in espocrm, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55184 in the wild and no public exploit code.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55184/ (Markdown: https://insights.sbomify.com/CVE-2026-55184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55184
- OSV: https://osv.dev/vulnerability/CVE-2026-55184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55184/
Summaries are generated and may contain mistakes; the official description above is the record.
