# CVE-2026-55195: py7zr: Decompression bomb (zip bomb) denial of service via unchecked extraction size

> Attackers can cause denial of service by submitting crafted 7z archives that expand excessively, exhausting system resources during extraction.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-55195, GHSA-gjrg-mpp7-g774, PYSEC-2026-2972, UBUNTU-CVE-2026-55195

## What is CVE-2026-55195?

CVE-2026-55195 is a high-severity denial of service vulnerability in miurahr py7zr, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

py7zr is a Python-based library and utility to support 7zip archive compression, decompression, encryption and decryption. Prior to 1.1.3, py7zr's Worker.decompress() extracted archive entries without tracking total decompressed size, allowing a crafted .7z file such as a 15.6 KB archive that expands to 100 MB to exhaust disk or memory before extraction completes. This issue is fixed in version 1.1.3.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-55195?

3 open source packages ship an affected version, including py7zr.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `py7zr` | PyPI | All versions | 1.1.3 |
| `py7zr` | PyPI | All versions | 1.1.3 |
| `py7zr` | PyPI | All versions | 1.1.3 |

## How do I fix CVE-2026-55195?

Upgrade py7zr to 1.1.3 or later.

## Is CVE-2026-55195 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55195 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55195 and fix it if it is affected.

What it is: CVE-2026-55195 is a high-severity denial of service vulnerability in miurahr py7zr, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55195 exists.

Affected packages and fixed versions:
- py7zr (PyPI): affected all versions; fixed in 1.1.3
- py7zr (PyPI): affected all versions; fixed in 1.1.3
- py7zr (PyPI): affected all versions; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55195/ (Markdown: https://insights.sbomify.com/CVE-2026-55195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55195
- OSV: https://osv.dev/vulnerability/CVE-2026-55195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55195/
Summaries are generated and may contain mistakes; the official description above is the record.
