CVE-2026-55204 HAProxy - NULL Pointer Dereference in hpack_dht_insert Function
An attacker can crash HAProxy worker processes by triggering a null pointer dereference during HPACK table insertions under memory pressure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55204?
CVE-2026-55204 is a high-severity vulnerability in haproxy, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HAProxy through 3.4.0, fixed in commit 9a6d1fe, contains a null pointer dereference vulnerability in hpack_dht_insert() within src/hpack-tbl.c that fails to validate the return value of hpack_dht_defrag() when the memory pool is exhausted. An attacker can trigger HPACK dynamic table insertions under memory pressure to dereference a NULL pointer and crash HAProxy worker processes, causing denial of service.
Weakness: CWE-476
Which versions are affected by CVE-2026-55204?
1 open source package ship an affected version, including haproxy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | All versions | 2.4.36, 2.6.30, 2.8.25, 3.0.24, 3.2.20, 3.4.1 |
Linux distribution packages (23)
haproxy AlmaLinux:8 | All versions | 1.8.27-5.el8_10.2 |
haproxy Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.27-5.el8_10.2 |
haproxy-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.27-5.el8_10.2 |
haproxy-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.27-5.el8_10.2 |
haproxy Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy-debuginfo Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy-debugsource Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy-debuginfo Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy-debugsource Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy Red Hat:rhel_e4s:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy-debuginfo Red Hat:rhel_e4s:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy-debugsource Red Hat:rhel_e4s:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy Red Hat:rhel_eus_long_life:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy-debuginfo Red Hat:rhel_eus_long_life:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy-debugsource Red Hat:rhel_eus_long_life:8.4::appstream | All versions | 0:1.8.27-2.el8_4.2 |
haproxy Red Hat:rhel_eus_long_life:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy-debuginfo Red Hat:rhel_eus_long_life:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy-debugsource Red Hat:rhel_eus_long_life:8.6::appstream | All versions | 0:1.8.27-4.el8_6.2 |
haproxy Red Hat:rhel_tus:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy-debuginfo Red Hat:rhel_tus:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy-debugsource Red Hat:rhel_tus:8.8::appstream | All versions | 0:1.8.27-5.el8_8.2 |
haproxy Rocky Linux:8 | All versions | 0:1.8.27-5.el8_10.2 |
Products include Haproxy Haproxy.
How do I fix CVE-2026-55204?
Upgrade haproxy to a fixed version for your release line: 2.4.36, 2.6.30, 2.8.25 or 3.0.24.
Is CVE-2026-55204 being exploited?
There is no known exploitation of CVE-2026-55204 in the wild and no public exploit code.
Other vulnerabilities in haproxy
Sources
Also known as ALSA-2026:55859, AZL-90261, BIT-haproxy-2026-55204, CLSA-2026-1782820521, CLSA-2026-1782825341, CLSA-2026-1782825734 and 20 more.