# CVE-2026-55211: surfio IRAP header size fields cause out-of-bounds reads

> Attackers can trigger out-of-bounds reads and potential code execution by providing malicious IRAP files to applications using the surfio library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-rcr2-hggw-43wm, PYSEC-2026-3701

## What is CVE-2026-55211?

CVE-2026-55211 is a critical memory corruption vulnerability in equinor surfio, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Surfio is a library for reading and writing surface files. Prior to 0.0.19, surfio does not correctly validate size fields in IRAP files, leading to a buffer overflow when untrusted files are parsed. The severity assumes surfio is used to parse untrusted files in a networking context such as a web service. This issue is fixed in version 0.0.19.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-55211?

3 open source packages ship an affected version, including surfio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surfio` | PyPI | All versions | 0.0.19 |
| `surfio` | PyPI | All versions | 0.0.19 |
| `surfio` | PyPI | All versions | 0.0.19 |

## How do I fix CVE-2026-55211?

Upgrade surfio to 0.0.19 or later.

## Is CVE-2026-55211 being exploited?

There is no known exploitation of CVE-2026-55211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55211 and fix it if it is affected.

What it is: CVE-2026-55211 is a critical memory corruption vulnerability in equinor surfio, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55211 in the wild and no public exploit code.

Affected packages and fixed versions:
- surfio (PyPI): affected all versions; fixed in 0.0.19
- surfio (PyPI): affected all versions; fixed in 0.0.19
- surfio (PyPI): affected all versions; fixed in 0.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55211/ (Markdown: https://insights.sbomify.com/CVE-2026-55211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55211
- OSV: https://osv.dev/vulnerability/CVE-2026-55211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55211/
Summaries are generated and may contain mistakes; the official description above is the record.
