CVE-2026-55212 Pimcore: Insufficient Permission Check on Class Definition Creation Endpoint Allows Privilege Escalation
Standard editors can create class definitions due to incorrect permission checks, leading to privilege escalation and potential code execution via generated files.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55212?
CVE-2026-55212 is a high-severity missing authorization vulnerability in pimcore, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Pimcore is an Open Source Data & Experience Management Platform. Prior to 2025.4.6 and 2026.1.6, the Studio API class definition creation endpoint POST /pimcore-studio/api/class/definition/configuration-view/detail/create is guarded by the objects permission instead of the classes permission, allowing a standard editor-level user to create class definitions without admin privileges. Class definition creation generates new database tables and PHP class files on the server, and missing API-layer UID format validation allows malformed UIDs to reach model-layer validation and return internal exceptions. This issue is fixed in versions 2025.4.6 and 2026.1.6.
Weakness: CWE-285
Which versions are affected by CVE-2026-55212?
4 open source packages ship an affected version, including pimcore/studio-backend-bundle.
| Package | Affected | Fixed in |
|---|---|---|
pimcore/studio-backend-bundle Packagist | All versions | 2026.1.6 |
pimcore/studio-backend-bundle Packagist | All versions | 2026.1.6 |
pimcore/studio-backend-bundle Packagist | From 2026.1.0 | 2026.1.6 |
pimcore/studio-backend-bundle Packagist | From 2026.1.0 | 2026.1.6 |
How do I fix CVE-2026-55212?
Upgrade pimcore/studio-backend-bundle to 2026.1.6 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55212 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55212 exists.
Sources
Also known as GHSA-f97c-ph8j-8vff.