CVE-2026-55215 MariaDB Connector/Node.js: Connector leaks the cleartext password to an MitM despite `ssl: true`
An active man-in-the-middle can capture cleartext database passwords from MariaDB Connector/Node.js when SSL is enabled without certificate pinning.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55215?
CVE-2026-55215 is a high-severity vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to versions 3.3.3, 3.4.6, and 3.5.3, when ssl is enabled without a pinned CA or server certificate, MariaDB Connector/Node.js sends credentials before completing certificate fingerprint validation. In lib/cmd/handshake/auth/handshake.js, a server that selects mysql_clear_password as the initial authentication plugin can receive the password before the post-TLS identity check. In lib/cmd/handshake/authentication.js, an authentication switch can evaluate the previous plugin instead of the requested target plugin, allowing mysql_clear_password to send the credential first. An active man-in-the-middle can present a self-signed certificate, capture the database password, and use it to authenticate directly even though the connector later rejects the server and closes the connection. This issue is fixed in versions 3.3.3, 3.4.6, and 3.5.3.
Which versions are affected by CVE-2026-55215?
11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 3.2.4 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | From 3.3.0 | 3.3.3 |
mariadb npm | From 3.3.0 | 3.3.3 |
mariadb npm | From 3.4.0 | 3.4.6 |
5 more packages
mariadb npm | From 3.4.0 | 3.4.6 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb-min Bitnami | All versions | 3.2.4 |
mysql-client Bitnami | All versions | 3.2.4 |
How do I fix CVE-2026-55215?
Upgrade mariadb to a fixed version for your release line: 3.2.4, 3.3.3, 3.4.6 or 3.5.3.
Is CVE-2026-55215 being exploited?
There is no known exploitation of CVE-2026-55215 in the wild and no public exploit code.
Sources
Also known as BIT-mariadb-2026-55215, BIT-mariadb-min-2026-55215, BIT-mysql-client-2026-55215, GHSA-cqhc-2h57-wpxf.