# CVE-2026-55219: Paymenter: Race condition in payWithCredit() enables credit double-spend

> Attackers can exploit a race condition to double-spend credit balances, causing financial loss to the platform.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-pgcq-8grm-5rx9

## What is CVE-2026-55219?

CVE-2026-55219 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.5, the credit payment implementation in app/Livewire/Invoices/Show.php executes a pessimistic row lock (lockForUpdate()) outside of an active database transaction. Because MySQL/MariaDB requires an enclosing transaction to enforce row-level locks, the guard is ineffective. Concurrent payment requests can exploit this race condition to read the same credit balance simultaneously, allowing users to pay multiple invoices using the same credit balance. In database systems like MySQL, a row lock only works inside a formal transaction; without one, the lock is completely ignored. Because there is no active lock, two payment requests sent at the exact same millisecond can look at the database at the same time. Both requests see the original credit balance, decide it is sufficient, and approve the payment. Because the payment processes successfully through ExtensionHelper::addPayment(), the application provisions the corresponding services or digital goods, resulting in direct financial or resource loss to the platform. This issue has been fixed in version 1.5.5.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-55219?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.5.5 |
| `paymenter/paymenter` | Packagist | All versions | 1.5.5 |

## How do I fix CVE-2026-55219?

Upgrade paymenter/paymenter to 1.5.5 or later.

## Is CVE-2026-55219 being exploited?

There is no known exploitation of CVE-2026-55219 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55219 and fix it if it is affected.

What it is: CVE-2026-55219 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55219 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.5
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55219/ (Markdown: https://insights.sbomify.com/CVE-2026-55219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55219
- OSV: https://osv.dev/vulnerability/CVE-2026-55219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55219/
Summaries are generated and may contain mistakes; the official description above is the record.
