CVE-2026-55220 Pimcore Hotspotimage getDataFromResource() unrestricted Serialize::unserialize over object-store column

Critical 9.3 Published Updated

Attackers with write access to specific database columns can trigger unsafe deserialization in Pimcore, leading to arbitrary code execution or file writes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55220?

CVE-2026-55220 is a critical unsafe deserialization vulnerability in pimcore, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.19, 12.3.10, and 2026.1.6, Pimcore\Model\DataObject\ClassDefinition\Data\Hotspotimage::getDataFromResource() in models/DataObject/ClassDefinition/Data/Hotspotimage.php passes the field __hotspots object-store column to Pimcore\Tool\Serialize::unserialize() without an allowed-classes restriction after JSON decoding fails. An attacker with a separate capability to write crafted PHP serialized bytes into that column can instantiate available classes and trigger magic methods when an affected DataObject is loaded, which can produce arbitrary file writes or code execution through bundled gadget chains. The related ImageGallery, Block, and Video callers use the same fallback pattern, but the identified June fix changes the Hotspotimage caller only. This issue is fixed for Hotspotimage in versions 11.5.19, 12.3.10, and 2026.1.6.

Weakness: CWE-502

Which versions are affected by CVE-2026-55220?

4 open source packages ship an affected version, including pimcore/pimcore.

PackageAffectedFixed in
pimcore/pimcore PackagistAll versions12.3.10
pimcore/pimcore PackagistAll versions12.3.10
pimcore/pimcore PackagistFrom 2026.1.02026.1.6
pimcore/pimcore PackagistFrom 2026.1.02026.1.6

How do I fix CVE-2026-55220?

Upgrade pimcore/pimcore to a fixed version for your release line: 12.3.10 or 2026.1.6.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-55220 being exploited?

There is no known exploitation of CVE-2026-55220 in the wild and no public exploit code.

Sources

Also known as GHSA-w23p-wrp7-ch38.

Is CVE-2026-55220 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free