# CVE-2026-55225: Strimzi: Cross-namespace privilege escalation via `Kafka.spec.entityOperator`

> Attackers with permission to create Kafka resources can escalate privileges to read or modify Secrets in arbitrary namespaces via the Entity Operator.

- **Severity:** High 8.0 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-mw9r-p8xp-wx96

## What is CVE-2026-55225?

CVE-2026-55225 is a high-severity vulnerability in strimzi-kafka-operator, published on 15 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Strimzi provides a way to run an Apache Kafka cluster on Kubernetes or OpenShift in various deployment configurations. In Strimzi 1.0.0 and earlier, an attacker who can create a Kafka custom resource can set Kafka.spec.entityOperator watchedNamespace to a target namespace, causing the Cluster Operator to create a Role with full Secret CRUD permissions there and bind it to the Entity Operator ServiceAccount in the attacker's namespace. The attacker can mint a token for that ServiceAccount and read or write Secrets in any target namespace where the Cluster Operator has been granted permissions, regardless of STRIMZI_NAMESPACE. This issue is fixed in versions 1.0.1 and 1.1.0.

Weakness: CWE-250 (Execution with Unnecessary Privileges), CWE-441 (Unintended Proxy or Intermediary), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-55225?

2 open source packages ship an affected version, including io.strimzi:strimzi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.strimzi:strimzi` | Maven | All versions | 1.0.1 |
| `io.strimzi:strimzi` | Maven | All versions | 1.0.1 |

## How do I fix CVE-2026-55225?

Upgrade io.strimzi:strimzi to 1.0.1 or later.

## Is CVE-2026-55225 being exploited?

There is no known exploitation of CVE-2026-55225 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55225 and fix it if it is affected.

What it is: CVE-2026-55225 is a high-severity vulnerability in strimzi-kafka-operator, published on 15 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55225 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.strimzi:strimzi (Maven): affected all versions; fixed in 1.0.1
- io.strimzi:strimzi (Maven): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55225/ (Markdown: https://insights.sbomify.com/CVE-2026-55225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55225
- OSV: https://osv.dev/vulnerability/CVE-2026-55225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55225/
Summaries are generated and may contain mistakes; the official description above is the record.
