# CVE-2026-55227: Observable object existence disclosure in private Weblate projects via globally scoped object lookups

> Attackers can infer the existence of objects in private Weblate projects by observing HTTP status code differences, leaking metadata about restricted content.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-2p9g-x3cv-5hh4, PYSEC-2026-3941

## What is CVE-2026-55227?

CVE-2026-55227 is a medium-severity vulnerability in WeblateOrg weblate, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web-based localization tool. In versions prior to 2026.7, several endpoints look up objects in a globally scoped manner rather than restricting the lookup to projects the user can access, so they return HTTP 403 (Forbidden) instead of 404 (Not Found) when a user requests an object they are not authorized to see. This difference lets unauthorized users infer whether a given object exists in a private Weblate project. The issue has been fixed in version 2026.7.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2026-55227?

3 open source packages ship an affected version, including weblate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 2026.7 |
| `weblate` | PyPI | All versions | 2026.7 |
| `weblate` | PyPI | All versions | 2026.7 |

## How do I fix CVE-2026-55227?

Upgrade weblate to 2026.7 or later.

## Is CVE-2026-55227 being exploited?

There is no known exploitation of CVE-2026-55227 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55227 and fix it if it is affected.

What it is: CVE-2026-55227 is a medium-severity vulnerability in WeblateOrg weblate, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55227 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 2026.7
- weblate (PyPI): affected all versions; fixed in 2026.7
- weblate (PyPI): affected all versions; fixed in 2026.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55227/ (Markdown: https://insights.sbomify.com/CVE-2026-55227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55227
- OSV: https://osv.dev/vulnerability/CVE-2026-55227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55227/
Summaries are generated and may contain mistakes; the official description above is the record.
