# CVE-2026-55232: Vvveb: Server-side request forgery in Vvveb via IPv6 bypass of validateUrl() in editor oEmbed proxy

> An authenticated admin can bypass SSRF protections using IPv6 to read internal services and cloud metadata via the oEmbed proxy.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-r6g4-5m3x-xrqj

## What is CVE-2026-55232?

CVE-2026-55232 is a high-severity server-side request forgery vulnerability in givanz Vvveb, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vvveb is a powerful and easy to use CMS with page builder to build websites, blogs or ecommerce stores. Prior to version 1.0.8.6, Vvveb's SSRF guard resolves a host with an IPv4-only function and never inspects IPv6, so any host that lacks an A record passes a private-range check. Editor oEmbed proxy fetches an attacker-supplied URL server side and reflects a response body, so an authenticated admin-panel user (default role site_admin or higher) can read internal-only services and cloud metadata, including IAM credentials, using an IPv6 literal or a domain that carries only an AAAA record. This issue has been patched in version 1.0.8.6.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-55232?


## How do I fix CVE-2026-55232?

No fix has been published for CVE-2026-55232 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55232 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55232 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55232 and fix it if it is affected.

What it is: CVE-2026-55232 is a high-severity server-side request forgery vulnerability in givanz Vvveb, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55232 exists.

Affected product: givanz Vvveb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55232/ (Markdown: https://insights.sbomify.com/CVE-2026-55232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55232
- OSV: https://osv.dev/vulnerability/CVE-2026-55232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55232/
Summaries are generated and may contain mistakes; the official description above is the record.
