CVE-2026-55233 OpenResty: Buffer overflow when writing PROXY protocol v2 header to upstream

High 7.5 Published Updated

An out-of-bounds write in OpenResty's PROXY protocol v2 implementation causes worker crashes, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-55233?

CVE-2026-55233 is a high-severity memory corruption vulnerability in openresty, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenResty is a high performance web platform. From 1.29.2.1 to before 1.29.2.5, an out-of-bounds write vulnerability exists in the upstream PROXY protocol v2 implementation. When OpenResty is configured to send PROXY protocol version 2 headers to upstream servers, constructing the header in the stream proxy protocol v2 patch can write beyond the bounds of the allocated buffer, causing the worker process to crash and resulting in a denial of service. Only configurations that explicitly enable PROXY protocol v2 for upstream connections are impacted. This issue is fixed in version 1.29.2.5.

Weakness: CWE-787

Which versions are affected by CVE-2026-55233?

It affects 1 product.

Products include Openresty Openresty.

How do I fix CVE-2026-55233?

No fix has been published for CVE-2026-55233 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-55233 being exploited?

There is no known exploitation of CVE-2026-55233 in the wild and no public exploit code.

Sources

Also known as GHSA-wx83-v28q-68gx.

Is CVE-2026-55233 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free