# CVE-2026-55233: OpenResty: Buffer overflow when writing PROXY protocol v2 header to upstream

> An out-of-bounds write in OpenResty's PROXY protocol v2 implementation causes worker crashes, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-wx83-v28q-68gx

## What is CVE-2026-55233?

CVE-2026-55233 is a high-severity memory corruption vulnerability in openresty, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenResty is a high performance web platform. From 1.29.2.1 to before 1.29.2.5, an out-of-bounds write vulnerability exists in the upstream PROXY protocol v2 implementation. When OpenResty is configured to send PROXY protocol version 2 headers to upstream servers, constructing the header in the stream proxy protocol v2 patch can write beyond the bounds of the allocated buffer, causing the worker process to crash and resulting in a denial of service. Only configurations that explicitly enable PROXY protocol v2 for upstream connections are impacted. This issue is fixed in version 1.29.2.5.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-55233?

It affects 1 product.


Products: Openresty Openresty.

## How do I fix CVE-2026-55233?

No fix has been published for CVE-2026-55233 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55233 being exploited?

There is no known exploitation of CVE-2026-55233 in the wild and no public exploit code.

## Other vulnerabilities in openresty

- [CVE-2018-9230](https://insights.sbomify.com/CVE-2018-9230/): Security feature bypass in n/a (critical 9.8)
- [CVE-2024-39702](https://insights.sbomify.com/CVE-2024-39702/): Denial of service in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55233 and fix it if it is affected.

What it is: CVE-2026-55233 is a high-severity memory corruption vulnerability in openresty, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55233 in the wild and no public exploit code.

Affected product: openresty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55233/ (Markdown: https://insights.sbomify.com/CVE-2026-55233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55233
- OSV: https://osv.dev/vulnerability/CVE-2026-55233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55233/
Summaries are generated and may contain mistakes; the official description above is the record.
