# CVE-2026-55235: langgraph-api: Relative webhook targets in LangGraph Server can reach in-process routes without authentication

> Authenticated users can bypass authorization checks to modify other users' threads via relative webhook targets in LangGraph Server.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-2c9q-c2q9-qgqv, PYSEC-2026-3857

## What is CVE-2026-55235?

CVE-2026-55235 is a medium-severity missing authorization vulnerability in langchain-ai langgraph-api, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

langgraph-api implements the LangGraph API for rapid development and testing. Prior to 0.10.0, langgraph-api permits a run or cron to specify a relative webhook target that is delivered through an in-process loopback transport, and the authentication middleware treats that transport as internal without applying the authentication context used for external requests. In deployments that rely on per-user authorization to separate threads and runs, an authenticated user can direct a webhook to the server's own thread and run routes, allowing creation of a run on or modification of another user's thread and limited incorporation of the targeted thread's metadata into the created run record. The affected path requires webhook targets and per-user authorization boundaries; deployments that deliberately re-enable loopback delivery should restrict it to controlled same-process routes because those webhooks remain unauthenticated. This issue is fixed in version 0.10.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-55235?

3 open source packages ship an affected version, including langgraph-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-api` | PyPI | All versions | 0.10.0 |
| `langgraph-api` | PyPI | All versions | 0.10.0 |
| `langgraph-api` | PyPI | All versions | 0.10.0 |

## How do I fix CVE-2026-55235?

Upgrade langgraph-api to 0.10.0 or later.

## Is CVE-2026-55235 being exploited?

There is no known exploitation of CVE-2026-55235 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55235 and fix it if it is affected.

What it is: CVE-2026-55235 is a medium-severity missing authorization vulnerability in langchain-ai langgraph-api, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55235 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55235/ (Markdown: https://insights.sbomify.com/CVE-2026-55235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55235
- OSV: https://osv.dev/vulnerability/CVE-2026-55235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55235/
Summaries are generated and may contain mistakes; the official description above is the record.
