# CVE-2026-55236: langgraph-api: Incomplete assistant authorization in LangGraph Server run creation

> Low-privileged users can access private assistant metadata and execute runs using other users' configurations in LangGraph Server deployments with specific custom authorization handlers.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-jfj5-wrj9-63x4, PYSEC-2026-3858

## What is CVE-2026-55236?

CVE-2026-55236 is a medium-severity missing authorization vulnerability in langchain-ai langgraph-api, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

langgraph-api implements the LangGraph API for rapid development and testing. Prior to 0.10.0, the langgraph-api run-creation path authorizes the assistant attached to a run by dispatching assistants.search with an incomplete value instead of the assistants.read event used by direct reads and cron creation. In deployments with custom resource handlers that register only assistants.read, omit an assistants.search handler, and have no global fallback handler, no applicable handler supplies an owner filter, allowing a low-privileged user to reference another user's private assistant through POST /runs or POST /threads/{thread_id}/runs. The run-creation response can disclose the private assistant's metadata, config, and context, and the run can execute using that assistant's configuration. Deployments without custom authorization handlers, or with an equivalent owner filter applied through a global handler or across all assistant events, are not affected. This issue is fixed in version 0.10.0.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-55236?

3 open source packages ship an affected version, including langgraph-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-api` | PyPI | All versions | 0.10.0 |
| `langgraph-api` | PyPI | All versions | 0.10.0 |
| `langgraph-api` | PyPI | All versions | 0.10.0 |

## How do I fix CVE-2026-55236?

Upgrade langgraph-api to 0.10.0 or later.

## Is CVE-2026-55236 being exploited?

There is no known exploitation of CVE-2026-55236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55236 and fix it if it is affected.

What it is: CVE-2026-55236 is a medium-severity missing authorization vulnerability in langchain-ai langgraph-api, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55236 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0
- langgraph-api (PyPI): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55236/ (Markdown: https://insights.sbomify.com/CVE-2026-55236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55236
- OSV: https://osv.dev/vulnerability/CVE-2026-55236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55236/
Summaries are generated and may contain mistakes; the official description above is the record.
