# CVE-2026-55240: Tianji: Remote Code Execution via lodash template evaluate pattern in survey feed templates

> A workspace administrator can inject JavaScript into survey templates, leading to remote code execution when unauthenticated users submit responses.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-5grg-j3cr-3hpm

## What is CVE-2026-55240?

CVE-2026-55240 is a critical code injection vulnerability in msgbyte tianji, published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Tianji is an open source analytics, uptime monitoring, and server status platform. Prior to 1.31.29, formatString() in src/server/utils/template.ts passes survey feedTemplate and monitor notification templates to lodash template(), while the default evaluate pattern remains enabled. A workspace administrator can store an evaluate block using the <% code %> form, and the public survey.submit endpoint renders a survey template when an unauthenticated user submits a response. The compiled template executes server-side JavaScript in the Tianji Node.js process, allowing command execution, secret disclosure, data modification, or service disruption. This issue is fixed in version 1.31.29.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-55240?


## How do I fix CVE-2026-55240?

No fix has been published for CVE-2026-55240 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55240 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55240 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55240 and fix it if it is affected.

What it is: CVE-2026-55240 is a critical code injection vulnerability in msgbyte tianji, published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55240 exists.

Affected product: msgbyte tianji. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55240/ (Markdown: https://insights.sbomify.com/CVE-2026-55240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55240
- OSV: https://osv.dev/vulnerability/CVE-2026-55240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55240/
Summaries are generated and may contain mistakes; the official description above is the record.
