CVE-2026-55247 plone.app.event: Denial of service via iCalendar import
A logged-in editor can trigger SSRF and resource exhaustion via iCalendar import, potentially taking the site offline and exposing internal resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55247?
CVE-2026-55247 is a critical server-side request forgery vulnerability in plone.app.event, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
plone.app.event provides the event content type for Plone. Prior to versions 5.2.4 and 6.0.1, the iCalendar import in src/plone/app/event/ical/importer.py accepts insufficiently restricted calendar and event URLs, does not adequately bound downloaded bytes or imported events, and commits work per event. A logged-in editor can make the server request internal network resources or local calendar files, exhaust resources and take the site offline, and store a malicious event URL that executes script in another user's browser. The fix restricts accepted URLs, applies MAXIMUM_ICAL_IMPORT_SIZE_BYTES and MAXIMUM_ICAL_IMPORT_EVENTS limits, uses transaction savepoints, and validates event URLs. This issue is fixed in versions 5.2.4 and 6.0.1.
Weakness: CWE-400
Which versions are affected by CVE-2026-55247?
5 open source packages ship an affected version, including plone.app.event and plone-app-event.
| Package | Affected | Fixed in |
|---|---|---|
plone.app.event PyPI | All versions | 5.2.4 |
plone.app.event PyPI | From 6.0.0a1 | 6.0.1 |
plone-app-event PyPI | All versions | 5.2.4, 6.0.1 |
plone-app-event PyPI | All versions | 5.2.4 |
plone-app-event PyPI | From 6.0.0a1 | 6.0.1 |
How do I fix CVE-2026-55247?
Upgrade plone.app.event to a fixed version for your release line: 5.2.4 or 6.0.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-55247 being exploited?
There is no known exploitation of CVE-2026-55247 in the wild and no public exploit code.
Sources
Also known as GHSA-r82h-mqw3-fc56, PYSEC-2026-3883.