# CVE-2026-55247: plone.app.event: Denial of service via iCalendar import

> A logged-in editor can trigger SSRF and resource exhaustion via iCalendar import, potentially taking the site offline and exposing internal resources.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-r82h-mqw3-fc56, PYSEC-2026-3883

## What is CVE-2026-55247?

CVE-2026-55247 is a critical server-side request forgery vulnerability in plone.app.event, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

plone.app.event provides the event content type for Plone. Prior to versions 5.2.4 and 6.0.1, the iCalendar import in src/plone/app/event/ical/importer.py accepts insufficiently restricted calendar and event URLs, does not adequately bound downloaded bytes or imported events, and commits work per event. A logged-in editor can make the server request internal network resources or local calendar files, exhaust resources and take the site offline, and store a malicious event URL that executes script in another user's browser. The fix restricts accepted URLs, applies MAXIMUM_ICAL_IMPORT_SIZE_BYTES and MAXIMUM_ICAL_IMPORT_EVENTS limits, uses transaction savepoints, and validates event URLs. This issue is fixed in versions 5.2.4 and 6.0.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55247?

5 open source packages ship an affected version, including plone.app.event and plone-app-event.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone.app.event` | PyPI | All versions | 5.2.4 |
| `plone.app.event` | PyPI | From 6.0.0a1 | 6.0.1 |
| `plone-app-event` | PyPI | All versions | 5.2.4, 6.0.1 |
| `plone-app-event` | PyPI | All versions | 5.2.4 |
| `plone-app-event` | PyPI | From 6.0.0a1 | 6.0.1 |

## How do I fix CVE-2026-55247?

Upgrade plone.app.event to a fixed version for your release line: 5.2.4 or 6.0.1.

## Is CVE-2026-55247 being exploited?

There is no known exploitation of CVE-2026-55247 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55247 and fix it if it is affected.

What it is: CVE-2026-55247 is a critical server-side request forgery vulnerability in plone.app.event, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55247 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone.app.event (PyPI): affected all versions; fixed in 5.2.4
- plone.app.event (PyPI): affected from 6.0.0a1; fixed in 6.0.1
- plone-app-event (PyPI): affected all versions; fixed in 5.2.4, 6.0.1
- plone-app-event (PyPI): affected all versions; fixed in 5.2.4
- plone-app-event (PyPI): affected from 6.0.0a1; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55247/ (Markdown: https://insights.sbomify.com/CVE-2026-55247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55247
- OSV: https://osv.dev/vulnerability/CVE-2026-55247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55247/
Summaries are generated and may contain mistakes; the official description above is the record.
