# CVE-2026-55253: LangChain MongoDB: NoSQL Operator Injection in MongoDBSaver.list() leading to cross-tenant data exposure

> Authenticated attackers can inject MongoDB operators to bypass tenant isolation and access other tenants' data in multi-tenant deployments.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-533j-2v4q-mw5h, PYSEC-2026-3859, PYSEC-2026-3860, ROOT-APP-PYPI-CVE-2026-55253

## What is CVE-2026-55253?

CVE-2026-55253 is a high-severity SQL injection vulnerability in langchain-ai langchain-mongodb, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangChain MongoDB provides integrations between MongoDB, Atlas, LangChain, and LangGraph. Prior to langgraph-checkpoint-mongodb 0.3.0 and langgraph-store-mongodb 0.4.0, MongoDBSaver.list(), MongoDBSaver.alist(), and MongoDBStore.search() incorporate filter dictionaries into MongoDB queries without recursively rejecting keys prefixed with $. An authenticated caller who controls a filter argument through HTTP query parameters, request body fields, or agent tool arguments can inject MongoDB Query Language operators such as $regex or $where. In a multi-tenant deployment that uses the filter to enforce per-user or per-tenant isolation, injected operators can bypass intended equality filtering and expose other tenants' checkpoint or store data. Filters constructed entirely from trusted server-side values have lower practical risk. This issue is fixed in langgraph-checkpoint-mongodb 0.3.0 and langgraph-store-mongodb 0.4.0.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2026-55253?

6 open source packages ship an affected version, including langgraph-checkpoint-mongodb and langgraph-store-mongodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-checkpoint-mongodb` | PyPI | All versions | 0.3.0 |
| `langgraph-checkpoint-mongodb` | PyPI | All versions | 0.3.0 |
| `langgraph-checkpoint-mongodb` | PyPI | All versions | 0.3.0 |
| `langgraph-store-mongodb` | PyPI | All versions | 0.4.0 |
| `langgraph-store-mongodb` | PyPI | All versions | 0.4.0 |
| `langgraph-store-mongodb` | PyPI | All versions | 0.4.0 |

## How do I fix CVE-2026-55253?

Upgrade langgraph-checkpoint-mongodb to 0.3.0 or later.

## Is CVE-2026-55253 being exploited?

There is no known exploitation of CVE-2026-55253 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55253 and fix it if it is affected.

What it is: CVE-2026-55253 is a high-severity SQL injection vulnerability in langchain-ai langchain-mongodb, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55253 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-checkpoint-mongodb (PyPI): affected all versions; fixed in 0.3.0
- langgraph-checkpoint-mongodb (PyPI): affected all versions; fixed in 0.3.0
- langgraph-checkpoint-mongodb (PyPI): affected all versions; fixed in 0.3.0
- langgraph-store-mongodb (PyPI): affected all versions; fixed in 0.4.0
- langgraph-store-mongodb (PyPI): affected all versions; fixed in 0.4.0
- langgraph-store-mongodb (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55253/ (Markdown: https://insights.sbomify.com/CVE-2026-55253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55253
- OSV: https://osv.dev/vulnerability/CVE-2026-55253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55253/
Summaries are generated and may contain mistakes; the official description above is the record.
