# CVE-2026-55369: Waline login accepts a non-string email as a match-all MongoDB query


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-jf75-q64q-g65r, GHSA-vvx2-3p2j-gx4m

## What is CVE-2026-55369?

CVE-2026-55369 is a medium-severity vulnerability in walinejs waline, published on 28 Oct 2026. 

### Official description

Waline is a comment system with backend support. Prior to version 1.41.1, the login endpoint POST /api/token reads the email field from the request body without checking its type and passes it straight into the MongoDB storage query. When email is not a string (for example a JSON object such as {"$ne": null}), the MongoDB storage adapter's parseWhere silently DROPS the field rather than rejecting the request, producing an empty filter that matches ALL users. The endpoint then verifies the submitted password against the FIRST user returned (user[0]), which in Waline is the first-registered user — the site administrator. This is a PARTIAL authentication bypass, not a full one. The attacker still needs a valid password for that first user; this is not a zero-knowledge bypass and it does not disclose passwords. Its concrete effects are: (1) the email/identifier factor is removed for the administrator account, (2) user enumeration (a non-string email never fails the "no such user" branch), and (3) credential-stuffing amplification — an attacker can test a leaked or weak password against the administrator account without knowing the administrator's email. This issue has been patched in version 1.41.1.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-55369?

2 open source packages ship an affected version, including @waline/vercel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@waline/vercel` | npm | All versions | 1.41.0 |
| `@waline/vercel` | npm | All versions | 1.41.0 |

## How do I fix CVE-2026-55369?

Upgrade @waline/vercel to 1.41.0 or later.

## Is CVE-2026-55369 being exploited?

There is no known exploitation of CVE-2026-55369 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55369 and fix it if it is affected.

What it is: CVE-2026-55369 is a medium-severity vulnerability in walinejs waline, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-55369 in the wild and no public exploit code.

Affected packages and fixed versions:
- @waline/vercel (npm): affected all versions; fixed in 1.41.0
- @waline/vercel (npm): affected all versions; fixed in 1.41.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55369/ (Markdown: https://insights.sbomify.com/CVE-2026-55369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55369
- OSV: https://osv.dev/vulnerability/CVE-2026-55369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55369/
Summaries are generated and may contain mistakes; the official description above is the record.
