# CVE-2026-55375: canto-saas-api: OAuth credentials exposed in URL query string and exception messages

> An attacker with access to logs or traces can steal OAuth credentials exposed in URLs and exceptions, allowing them to obtain access tokens for the tenant.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-37pm-83g7-r22v

## What is CVE-2026-55375?

CVE-2026-55375 is a medium-severity vulnerability in jleehr canto-saas-api, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

canto-saas-api is a PHP library for interacting with the Canto SaaS API. Prior to version 3.0.0, OAuth2Request::getQueryParams() places app_id, app_secret, refresh_token, and code in the URL query string of token POST requests, allowing access logs, proxy logs, and APM traces to persist the credentials in plaintext. When a token request fails, OAuth2::obtainAccessToken() also passes the credential-bearing Guzzle request URI into AuthorizationFailedException, so application logs and error trackers can record the same secrets. An attacker with access to affected telemetry can obtain Canto credentials and use them to request access tokens for the tenant. This issue is fixed in version 3.0.0.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String), CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-55375?

2 open source packages ship an affected version, including jleehr/canto-saas-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jleehr/canto-saas-api` | Packagist | All versions | 3.0.0 |
| `jleehr/canto-saas-api` | Packagist | All versions | 3.0.0 |

## How do I fix CVE-2026-55375?

Upgrade jleehr/canto-saas-api to 3.0.0 or later.

## Is CVE-2026-55375 being exploited?

There is no known exploitation of CVE-2026-55375 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55375 and fix it if it is affected.

What it is: CVE-2026-55375 is a medium-severity vulnerability in jleehr canto-saas-api, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55375 in the wild and no public exploit code.

Affected packages and fixed versions:
- jleehr/canto-saas-api (Packagist): affected all versions; fixed in 3.0.0
- jleehr/canto-saas-api (Packagist): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55375/ (Markdown: https://insights.sbomify.com/CVE-2026-55375/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55375
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55375
- OSV: https://osv.dev/vulnerability/CVE-2026-55375

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55375/
Summaries are generated and may contain mistakes; the official description above is the record.
