# CVE-2026-55379: Pillow `BdfFontFile`: `Image.new()` called without `_decompression_bomb_check()` — bomb protection bypass via font loading

> Attackers can cause excessive memory allocation and denial of service by loading malicious BDF font files that bypass Pillow's decompression bomb protection.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** BIT-pillow-2026-55379, DEBIAN-CVE-2026-55379, ECHO-f7cd-a473-7e12, GHSA-45hq-cxwh-f6vc, MINI-43g3-m8hg-xcfj, MINI-4vqv-3q85-gg66, MINI-59jr-g9w4-qv94, MINI-6562-f243-wv8f, MINI-7385-6f73-hfq8, MINI-7937-wx66-28p9, MINI-83jm-hvj9-xg8x, MINI-h86x-m76x-j543, MINI-rj6c-36p7-hxq5, MINI-x7q8-vmj7-c77r, MINI-xw2j-g6hj-fw6c, PYSEC-2026-2255, ROOT-APP-PYPI-CVE-2026-55379, UBUNTU-CVE-2026-55379

## What is CVE-2026-55379?

CVE-2026-55379 is a high-severity denial of service vulnerability in Python Pillow, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. Prior to 12.3.0, PIL/BdfFontFile.py bdf_char() read the BBX width and height field from a BDF font file and passed attacker-controlled dimensions to Image.new() without calling Image._decompression_bomb_check(), bypassing Pillow's documented decompression bomb protection and allowing excessive memory allocation. This issue is fixed in version 12.3.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-55379?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |

Products: Python Pillow.

## How do I fix CVE-2026-55379?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-55379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55379 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55379 and fix it if it is affected.

What it is: CVE-2026-55379 is a high-severity denial of service vulnerability in Python Pillow, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55379 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55379/ (Markdown: https://insights.sbomify.com/CVE-2026-55379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55379
- OSV: https://osv.dev/vulnerability/CVE-2026-55379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55379/
Summaries are generated and may contain mistakes; the official description above is the record.
