# CVE-2026-55389: datamodel-code-generator vulnerable to arbitrary local file read via JSON-Schema `$ref` (`file://` and `../` traversal), bypassing `--no-allow-remote-refs`

> Attackers can read arbitrary local files by exploiting JSON-Schema reference resolution, bypassing remote reference restrictions in datamodel-code-generator.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-8359-h9fx-j6v9, MINI-6qc7-gqgq-433m, PYSEC-2026-3558

## What is CVE-2026-55389?

CVE-2026-55389 is a high-severity path traversal vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

datamodel-code-generator generates Pydantic v2 models, dataclasses, TypedDict, and msgspec.Struct from OpenAPI, JSON Schema, GraphQL, Avro, Protobuf, and raw JSON, YAML, or CSV. Prior to 0.62.0, datamodel-code-generator resolves JSON Schema $ref targets in src/datamodel_code_generator/parser/jsonschema.py through is_url and _get_ref_body without containing file:// or ../ traversal references to the input directory and without honoring --no-allow-remote-refs, allowing arbitrary local file reads. This issue is fixed in version 0.62.0.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55389?

3 open source packages ship an affected version, including datamodel-code-generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datamodel-code-generator` | PyPI | All versions | 0.62.0 |
| `datamodel-code-generator` | PyPI | All versions | 0.62.0 |
| `datamodel-code-generator` | PyPI | All versions | 0.62.0 |

Products: Koxudaxi Datamodel-Code-Generator.

## How do I fix CVE-2026-55389?

Upgrade datamodel-code-generator to 0.62.0 or later.

## Is CVE-2026-55389 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55389 exists.

## Other vulnerabilities in koxudaxi datamodel-code-generator

- [CVE-2026-54653](https://insights.sbomify.com/CVE-2026-54653/): `datamodel-code-generator` vulnerable to code injection in via attacker-controlled `default_factory` schema field (high 8.8)
- [CVE-2026-54690](https://insights.sbomify.com/CVE-2026-54690/): datamodel-code-generator vulnerable to SSRF via JSON-Schema `$ref` to HTTP URL (silent by default) (high 8.2)
- [CVE-2026-54656](https://insights.sbomify.com/CVE-2026-54656/): `datamodel-code-generator` vulnerable to code execution on import via unescaped `validators` entries in --extra-template-data (high 7.8)
- [CVE-2026-55391](https://insights.sbomify.com/CVE-2026-55391/): datamodel-code-generator vulnerable to SSRF protection bypass via DNS rebinding (high 7.5)
- [CVE-2026-55415](https://insights.sbomify.com/CVE-2026-55415/): datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55389 and fix it if it is affected.

What it is: CVE-2026-55389 is a high-severity path traversal vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55389 exists.

Affected packages and fixed versions:
- datamodel-code-generator (PyPI): affected all versions; fixed in 0.62.0
- datamodel-code-generator (PyPI): affected all versions; fixed in 0.62.0
- datamodel-code-generator (PyPI): affected all versions; fixed in 0.62.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55389/ (Markdown: https://insights.sbomify.com/CVE-2026-55389/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55389
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55389
- OSV: https://osv.dev/vulnerability/CVE-2026-55389

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55389/
Summaries are generated and may contain mistakes; the official description above is the record.
