{"answers":{"affected":"3 open source packages ship an affected version, including yt-dlp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-55404 in the wild and no public exploit code.","fix":"Upgrade yt-dlp to 2026.7.4 or later.","what":"CVE-2026-55404 is a high-severity command injection vulnerability in yt-dlp, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55404 and fix it if it is affected.\n\nWhat it is: CVE-2026-55404 is a high-severity command injection vulnerability in yt-dlp, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-55404 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yt-dlp (PyPI): affected all versions; fixed in 2026.7.4\n- yt-dlp (PyPI): affected all versions; fixed in 2026.7.4\n- yt-dlp (PyPI): affected all versions; fixed in 2026.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55404/ (Markdown: https://insights.sbomify.com/CVE-2026-55404/index.md)","id":"CVE-2026-55404","markdown":"https://insights.sbomify.com/CVE-2026-55404/index.md","name":"CVE-2026-55404","record":{"aliases":["DEBIAN-CVE-2026-55404","GHSA-6v4j-43gg-vj32","PYSEC-2026-3622","UBUNTU-CVE-2026-55404","openSUSE-SU-2026:11196-1","openSUSE-SU-2026:22142-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"yt-dlp downloader","requires_auth":"none","summary":"Attackers can inject malicious commands via crafted metadata in yt-dlp shortcut files, leading to code execution when opened.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yt-dlp","vendor":"yt-dlp_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"yt-dlp and youtube-dl are command-line audio/video downloaders. Prior to 2026.7.4, the --write-link, --write-url-link, and --write-desktop-link options can write .url or .desktop shortcut files using attacker-controlled webpage_url or filename metadata without sufficient validation or escaping, allowing malicious file:// URI injection on Windows or newline-based desktop entry key injection on Linux that can execute commands if the generated shortcut is opened. This issue is fixed in version 2026.7.4.","ecosystems":["PyPI","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"yt-dlp: Downstream command injection via improper sanitization of yt-dlp --write-link output","id":"CVE-2026-55404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":5,"n_references":3,"next":{"headline":"LangChain4j: SQL injection via metadata filters in langchain4j-mariadb and langchain4j-pgvector","id":"CVE-2026-55405"},"packages":[{"ecosystem":"PyPI","fixed":["2026.7.4"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":null,"source":"GHSA-6v4j-43gg-vj32"},{"ecosystem":"PyPI","fixed":["2026.7.4"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":"pkg:pypi/yt-dlp","source":"GHSA-6v4j-43gg-vj32"},{"ecosystem":"PyPI","fixed":["2026.7.4"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":"pkg:pypi/yt-dlp","source":"PYSEC-2026-3622"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["2026.08.19-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":"pkg:rpm/opensuse/yt-dlp\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:22142-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2026.07.04-1.1"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":"pkg:rpm/opensuse/yt-dlp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11196-1"}],"prev":{"headline":"datamodel-code-generator: Authorization / request headers leaked to cross-origin redirect target when fetching remote schemas","id":"CVE-2026-55403"},"products":["yt-dlp"],"published":"2026-07-08","related":[{"cvss_score":8.8,"headline":"yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option","id":"CVE-2026-26331","kev_date_added":null,"published":"2026-02-24"},{"cvss_score":8.4,"headline":"yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows","id":"CVE-2024-22423","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":8.4,"headline":"yt-dlp command injection when using `%q` in `--exec` on Windows","id":"CVE-2023-40581","kev_date_added":null,"published":"2023-09-25"},{"cvss_score":8.3,"headline":"yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)","id":"CVE-2026-50023","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":8.3,"headline":"yt-dlp: Arbitrary code execution via manifest downloads with aria2c","id":"CVE-2026-50574","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":7.5,"headline":"yt-dlp allows `--exec` command injection when using placeholder on Windows","id":"CVE-2025-54072","kev_date_added":null,"published":"2025-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["yt-dlp"]},"summary":"Attackers can inject malicious commands via crafted metadata in yt-dlp shortcut files, leading to code execution when opened.","url":"https://insights.sbomify.com/CVE-2026-55404/"}