CVE-2026-55405 LangChain4j: SQL injection via metadata filters in langchain4j-mariadb and langchain4j-pgvector
Attackers can inject arbitrary SQL via crafted metadata filters in LangChain4j MariaDB and pgvector stores, enabling data exfiltration, modification, or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55405?
CVE-2026-55405 is a high-severity SQL injection vulnerability in langchain4j, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
LangChain4j is a Java library for building LLM-powered applications on the JVM. Prior to 1.2.1-beta8, 1.5.1-beta11, 1.11.8-beta19, and 1.16.3-beta26, the MariaDB and pgvector embedding stores build metadata-filter SQL by string-concatenating filter keys, and in MariaDB string values, directly into the query without adequate escaping. A crafted metadata key in EmbeddingSearchRequest.filter() can break out of its SQL context and inject arbitrary SQL into the statements executed by the stores' search and removeAll(Filter) operations, enabling blind data exfiltration, denial of service via sleep functions, and deletion of arbitrary rows through removeAll(Filter). This issue is fixed in langchain4j-mariadb and langchain4j-pgvector versions 1.2.1-beta8, 1.5.1-beta11, 1.11.8-beta19, and 1.16.3-beta26.
Weakness: CWE-89
Which versions are affected by CVE-2026-55405?
16 open source packages ship an affected version, including dev.langchain4j:langchain4j-mariadb and dev.langchain4j:langchain4j-pgvector.
| Package | Affected | Fixed in |
|---|---|---|
dev.langchain4j:langchain4j-mariadb Maven | All versions | 1.2.1-beta8 |
dev.langchain4j:langchain4j-mariadb Maven | All versions | 1.2.1-beta8 |
dev.langchain4j:langchain4j-mariadb Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
dev.langchain4j:langchain4j-mariadb Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
dev.langchain4j:langchain4j-mariadb Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
dev.langchain4j:langchain4j-mariadb Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
10 more packages
dev.langchain4j:langchain4j-mariadb Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
dev.langchain4j:langchain4j-mariadb Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
dev.langchain4j:langchain4j-pgvector Maven | All versions | 1.2.1-beta8 |
dev.langchain4j:langchain4j-pgvector Maven | All versions | 1.2.1-beta8 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
dev.langchain4j:langchain4j-pgvector Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
How do I fix CVE-2026-55405?
Upgrade dev.langchain4j:langchain4j-mariadb to a fixed version for your release line: 1.2.1-beta8, 1.16.3-beta26, 1.5.1-beta11 or 1.11.8-beta19.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-55405 being exploited?
There is no known exploitation of CVE-2026-55405 in the wild and no public exploit code.
Sources
Also known as GHSA-2mfg-cc43-9pcj.