# CVE-2026-55405: LangChain4j: SQL injection via metadata filters in langchain4j-mariadb and langchain4j-pgvector

> Attackers can inject arbitrary SQL via crafted metadata filters in LangChain4j MariaDB and pgvector stores, enabling data exfiltration, modification, or denial of service.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-2mfg-cc43-9pcj

## What is CVE-2026-55405?

CVE-2026-55405 is a high-severity SQL injection vulnerability in langchain4j, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangChain4j is a Java library for building LLM-powered applications on the JVM. Prior to  1.2.1-beta8, 1.5.1-beta11, 1.11.8-beta19, and 1.16.3-beta26, the MariaDB and pgvector embedding stores build metadata-filter SQL by string-concatenating filter keys, and in MariaDB string values, directly into the query without adequate escaping. A crafted metadata key in EmbeddingSearchRequest.filter() can break out of its SQL context and inject arbitrary SQL into the statements executed by the stores' search and removeAll(Filter) operations, enabling blind data exfiltration, denial of service via sleep functions, and deletion of arbitrary rows through removeAll(Filter). This issue is fixed in langchain4j-mariadb and langchain4j-pgvector versions 1.2.1-beta8, 1.5.1-beta11, 1.11.8-beta19, and 1.16.3-beta26.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-55405?

16 open source packages ship an affected version, including dev.langchain4j:langchain4j-mariadb and dev.langchain4j:langchain4j-pgvector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dev.langchain4j:langchain4j-mariadb` | Maven | All versions | 1.2.1-beta8 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | All versions | 1.2.1-beta8 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
| `dev.langchain4j:langchain4j-mariadb` | Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | All versions | 1.2.1-beta8 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | All versions | 1.2.1-beta8 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.12.1-beta21 | 1.16.3-beta26 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.3.0-beta9 | 1.5.1-beta11 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.6.0-beta12 | 1.11.8-beta19 |
| `dev.langchain4j:langchain4j-pgvector` | Maven | From 1.6.0-beta12 | 1.11.8-beta19 |

## How do I fix CVE-2026-55405?

Upgrade dev.langchain4j:langchain4j-mariadb to a fixed version for your release line: 1.2.1-beta8, 1.16.3-beta26, 1.5.1-beta11 or 1.11.8-beta19.

## Is CVE-2026-55405 being exploited?

There is no known exploitation of CVE-2026-55405 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55405 and fix it if it is affected.

What it is: CVE-2026-55405 is a high-severity SQL injection vulnerability in langchain4j, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55405 in the wild and no public exploit code.

Affected packages and fixed versions:
- dev.langchain4j:langchain4j-mariadb (Maven): affected all versions; fixed in 1.2.1-beta8
- dev.langchain4j:langchain4j-mariadb (Maven): affected all versions; fixed in 1.2.1-beta8
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.12.1-beta21; fixed in 1.16.3-beta26
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.12.1-beta21; fixed in 1.16.3-beta26
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.3.0-beta9; fixed in 1.5.1-beta11
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.3.0-beta9; fixed in 1.5.1-beta11
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.6.0-beta12; fixed in 1.11.8-beta19
- dev.langchain4j:langchain4j-mariadb (Maven): affected from 1.6.0-beta12; fixed in 1.11.8-beta19
- dev.langchain4j:langchain4j-pgvector (Maven): affected all versions; fixed in 1.2.1-beta8
- dev.langchain4j:langchain4j-pgvector (Maven): affected all versions; fixed in 1.2.1-beta8
- dev.langchain4j:langchain4j-pgvector (Maven): affected from 1.12.1-beta21; fixed in 1.16.3-beta26
- dev.langchain4j:langchain4j-pgvector (Maven): affected from 1.12.1-beta21; fixed in 1.16.3-beta26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55405/ (Markdown: https://insights.sbomify.com/CVE-2026-55405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55405
- OSV: https://osv.dev/vulnerability/CVE-2026-55405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55405/
Summaries are generated and may contain mistakes; the official description above is the record.
