# CVE-2026-55408: Koodo Reader: Remote code execution via malicious epub file

> Attackers can execute arbitrary code via malicious EPUB files in Koodo Reader due to unsafe IPC handling and unsanitized HTML rendering.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-mjr7-w4jq-2rq9

## What is CVE-2026-55408?

CVE-2026-55408 is a high-severity code injection vulnerability in koodo-reader, published on 7 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Koodo Reader is an ebook reader. In version 2.3.0 and earlier, Koodo Reader is vulnerable to remote code execution through malicious EPUB files because the open-book IPC handler enables nodeIntegrationInSubFrames and EPUB chapter content is rendered with unsanitized innerHTML. An attacker can craft an EPUB book that, when imported and opened by the victim, instantiates a hidden iframe with Node.js API access and executes arbitrary operating system commands with the victim user's privileges. This issue is fixed in version 2.3.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55408?


## How do I fix CVE-2026-55408?

No fix has been published for CVE-2026-55408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55408 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55408 and fix it if it is affected.

What it is: CVE-2026-55408 is a high-severity code injection vulnerability in koodo-reader, published on 7 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55408 exists.

Affected product: koodo-reader. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55408/ (Markdown: https://insights.sbomify.com/CVE-2026-55408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55408
- OSV: https://osv.dev/vulnerability/CVE-2026-55408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55408/
Summaries are generated and may contain mistakes; the official description above is the record.
