{"answers":{"affected":"2 open source packages ship an affected version, including filament/forms.","exploited":"There is no known exploitation of CVE-2026-55409 in the wild and no public exploit code.","fix":"Upgrade filament/forms to 3.3.53 or later.","what":"CVE-2026-55409 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55409 and fix it if it is affected.\n\nWhat it is: CVE-2026-55409 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-55409 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- filament/forms (Packagist): affected from 3.0.0; fixed in 3.3.53\n- filament/forms (Packagist): affected from 3.0.0; fixed in 3.3.53\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55409/ (Markdown: https://insights.sbomify.com/CVE-2026-55409/index.md)","id":"CVE-2026-55409","markdown":"https://insights.sbomify.com/CVE-2026-55409/index.md","name":"CVE-2026-55409","record":{"aliases":["GHSA-m9cv-24rx-8mv7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Filament Laravel components","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into disabled RichEditor fields, leading to XSS execution for users viewing the form.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Filament is a collection of full-stack components for accelerated Laravel development. From 3.0.0 until 3.3.53, a disabled RichEditor field rendered its raw state without sanitizing HTML. Where the data stored in this field's state isn't sanitized already when the form state was filled, an attacker could plant malicious HTML or JavaScript and achieve XSS that executes for users who view the form. This vulnerability is fixed in 3.3.53.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Filament: Disabled RichEditor field state can be used for XSS","id":"CVE-2026-55409","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"NocoBase backup restore schema name allows command injection","id":"CVE-2026-55410"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.53"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/forms","purl":null,"source":"GHSA-m9cv-24rx-8mv7"},{"ecosystem":"Packagist","fixed":["3.3.53"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/forms","purl":"pkg:composer/filament/forms","source":"GHSA-m9cv-24rx-8mv7"}],"prev":{"headline":"Koodo Reader: Remote code execution via malicious epub file","id":"CVE-2026-55408"},"products":["filament"],"published":"2026-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["filamentphp"]},"summary":"Attackers can inject malicious scripts into disabled RichEditor fields, leading to XSS execution for users viewing the form.","url":"https://insights.sbomify.com/CVE-2026-55409/"}