# CVE-2026-55409: Filament: Disabled RichEditor field state can be used for XSS

> Attackers can inject malicious scripts into disabled RichEditor fields, leading to XSS execution for users viewing the form.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-m9cv-24rx-8mv7

## What is CVE-2026-55409?

CVE-2026-55409 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Filament is a collection of full-stack components for accelerated Laravel development. From 3.0.0 until 3.3.53, a disabled RichEditor field rendered its raw state without sanitizing HTML. Where the data stored in this field's state isn't sanitized already when the form state was filled, an attacker could plant malicious HTML or JavaScript and achieve XSS that executes for users who view the form. This vulnerability is fixed in 3.3.53.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55409?

2 open source packages ship an affected version, including filament/forms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filament/forms` | Packagist | From 3.0.0 | 3.3.53 |
| `filament/forms` | Packagist | From 3.0.0 | 3.3.53 |

## How do I fix CVE-2026-55409?

Upgrade filament/forms to 3.3.53 or later.

## Is CVE-2026-55409 being exploited?

There is no known exploitation of CVE-2026-55409 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55409 and fix it if it is affected.

What it is: CVE-2026-55409 is a high-severity cross-site scripting vulnerability in filamentphp filament, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55409 in the wild and no public exploit code.

Affected packages and fixed versions:
- filament/forms (Packagist): affected from 3.0.0; fixed in 3.3.53
- filament/forms (Packagist): affected from 3.0.0; fixed in 3.3.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55409/ (Markdown: https://insights.sbomify.com/CVE-2026-55409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55409
- OSV: https://osv.dev/vulnerability/CVE-2026-55409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55409/
Summaries are generated and may contain mistakes; the official description above is the record.
