{"answers":{"affected":"2 open source packages ship an affected version, including @nocobase/plugin-backups.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55410 exists.","fix":"Upgrade @nocobase/plugin-backups to 2.1.19 or later.","what":"CVE-2026-55410 is a medium-severity command injection vulnerability in nocobase, published on 15 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55410 and fix it if it is affected.\n\nWhat it is: CVE-2026-55410 is a medium-severity command injection vulnerability in nocobase, published on 15 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55410 exists.\n\nAffected packages and fixed versions:\n- @nocobase/plugin-backups (npm): affected all versions; fixed in 2.1.19\n- @nocobase/plugin-backups (npm): affected all versions; fixed in 2.1.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55410/ (Markdown: https://insights.sbomify.com/CVE-2026-55410/index.md)","id":"CVE-2026-55410","markdown":"https://insights.sbomify.com/CVE-2026-55410/index.md","name":"CVE-2026-55410","record":{"aliases":["GHSA-p853-83gj-wjj3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"NocoBase no-code platform","requires_auth":"high_privilege","summary":"A backup-management user can execute arbitrary commands on the server by restoring a crafted PostgreSQL backup with a malicious schema name.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"NocoBase is an AI-powered no-code/low-code platform for building business applications and enterprise solutions. Prior to 2.1.19, NocoBase @nocobase/plugin-backups restored PostgreSQL backups by interpolating the database.schema value from _metadata.json into shell command strings executed with Node.js child_process.exec(), allowing a backup-management user restoring a crafted backup to execute commands as the NocoBase server process. This vulnerability is fixed in 2.1.19.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NocoBase backup restore schema name allows command injection","id":"CVE-2026-55410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in ToolJet","id":"CVE-2026-55411"},"packages":[{"ecosystem":"npm","fixed":["2.1.19"],"introduced":["0"],"last_affected":[],"package":"@nocobase/plugin-backups","purl":null,"source":"GHSA-p853-83gj-wjj3"},{"ecosystem":"npm","fixed":["2.1.19"],"introduced":["0"],"last_affected":[],"package":"@nocobase/plugin-backups","purl":"pkg:npm/%40nocobase/plugin-backups","source":"GHSA-p853-83gj-wjj3"}],"prev":{"headline":"Filament: Disabled RichEditor field state can be used for XSS","id":"CVE-2026-55409"},"products":["nocobase"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-18","vendors":["nocobase"]},"summary":"A backup-management user can execute arbitrary commands on the server by restoring a crafted PostgreSQL backup with a malicious schema name.","url":"https://insights.sbomify.com/CVE-2026-55410/"}