# CVE-2026-55410: NocoBase backup restore schema name allows command injection

> A backup-management user can execute arbitrary commands on the server by restoring a crafted PostgreSQL backup with a malicious schema name.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-p853-83gj-wjj3

## What is CVE-2026-55410?

CVE-2026-55410 is a medium-severity command injection vulnerability in nocobase, published on 15 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NocoBase is an AI-powered no-code/low-code platform for building business applications and enterprise solutions. Prior to 2.1.19, NocoBase @nocobase/plugin-backups restored PostgreSQL backups by interpolating the database.schema value from _metadata.json into shell command strings executed with Node.js child_process.exec(), allowing a backup-management user restoring a crafted backup to execute commands as the NocoBase server process. This vulnerability is fixed in 2.1.19.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55410?

2 open source packages ship an affected version, including @nocobase/plugin-backups.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nocobase/plugin-backups` | npm | All versions | 2.1.19 |
| `@nocobase/plugin-backups` | npm | All versions | 2.1.19 |

## How do I fix CVE-2026-55410?

Upgrade @nocobase/plugin-backups to 2.1.19 or later.

## Is CVE-2026-55410 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55410 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55410 and fix it if it is affected.

What it is: CVE-2026-55410 is a medium-severity command injection vulnerability in nocobase, published on 15 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55410 exists.

Affected packages and fixed versions:
- @nocobase/plugin-backups (npm): affected all versions; fixed in 2.1.19
- @nocobase/plugin-backups (npm): affected all versions; fixed in 2.1.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55410/ (Markdown: https://insights.sbomify.com/CVE-2026-55410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55410
- OSV: https://osv.dev/vulnerability/CVE-2026-55410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55410/
Summaries are generated and may contain mistakes; the official description above is the record.
