CVE-2026-55414 NL Portal Backend Libraries: Unauthenticated form resolver forwards the privileged Objecten-API token to a caller-supplied URL (SSRF)
Unauthenticated attackers can trigger SSRF to leak privileged API tokens by manipulating form resolver URLs in NL Portal backend libraries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55414?
CVE-2026-55414 is a medium-severity server-side request forgery vulnerability in nl-portal-backend-libraries, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NL Portal Backend Libraries provide backend components for Dutch government portals that interact with residents, customers, suppliers, and partner organizations. From 1.1.0 until 3.0.4, and in 3.1.0, the public getFormDefinitionByObjectenApiUrl and deprecated getFormDefinitionById GraphQL resolvers are reachable without CommonGroundAuthentication and forward a caller-influenced URL through ObjectenApiService.getObjectByUrl to ObjectsApiClient.getObjectByUrl, which attaches the privileged Objecten-API token. The host-equality check restricts requests to the configured Objecten-API host but does not constrain the scheme, port, or path, allowing an unauthenticated caller to induce a token-bearing request to a chosen endpoint on that host. Standard deployments are not exposed to cross-host SSRF, token capture requires attacker-controlled routing on the configured host, and typed deserialization limits returned data to objects shaped like form definitions. The 3.0 release line is fixed in version 3.0.4. The advisory does not identify a fixed 3.1 release.
Which versions are affected by CVE-2026-55414?
2 open source packages ship an affected version, including nl.nl-portal:form.
| Package | Affected | Fixed in |
|---|---|---|
nl.nl-portal:form Maven | From 1.1.0 | 3.0.4 |
nl.nl-portal:form Maven | From 1.1.0 | 3.0.4 |
How do I fix CVE-2026-55414?
Upgrade nl.nl-portal:form to 3.0.4 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-55414 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55414 exists.
Sources
Also known as GHSA-xm3x-9cfw-jhx4.