CVE-2026-55415 datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements

High 7.5 Published Updated

Attackers can execute arbitrary Python code by injecting newlines into schema extensions, affecting users of datamodel-code-generator.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-55415?

CVE-2026-55415 is a high-severity code injection vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

datamodel-code-generator generates Pydantic v2 models, dataclasses, TypedDict, and msgspec.Struct from OpenAPI, JSON Schema, GraphQL, Avro, Protobuf, and raw JSON, YAML, or CSV. From 0.11.6 until 0.64.0, datamodel-code-generator allows attacker-controlled x-python-import or customTypePath schema extensions to reach src/datamodel_code_generator/parser/jsonschema.py and generated import handling through Import.from_full_path and Imports.create_line in src/datamodel_code_generator/imports.py, allowing a newline to break out of an import statement and execute Python code when the generated model is imported. This issue is fixed in version 0.64.0.

Weakness: CWE-95, CWE-94

Which versions are affected by CVE-2026-55415?

3 open source packages ship an affected version, including datamodel-code-generator. It affects 1 product.

PackageAffectedFixed in
datamodel-code-generator PyPIFrom 0.11.60.64.0
datamodel-code-generator PyPIFrom 0.11.60.64.0
datamodel-code-generator PyPIFrom 0.11.60.64.0

Products include Koxudaxi Datamodel-Code-Generator.

How do I fix CVE-2026-55415?

Upgrade datamodel-code-generator to 0.64.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-55415 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55415 exists.

Sources

Also known as GHSA-5578-w22f-pfx9, MINI-fm2f-2g97-vp49, PYSEC-2026-3557.

Is CVE-2026-55415 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free