# CVE-2026-55419: Reachy Mini: Unrestricted Upload of File with Dangerous Type

> Unauthenticated attackers can upload arbitrary files to Reachy Mini robots, compromising data integrity and potentially enabling code execution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-m2pc-3q4q-w6jr, PYSEC-2026-3916

## What is CVE-2026-55419?

CVE-2026-55419 is a medium-severity vulnerability in pollen-robotics reachy_mini, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Reachy Mini is an SDK for controlling Reachy Mini robots. Prior to 1.8.2, the Reachy Mini daemon exposes the /api/media/sounds/upload endpoint implemented by the upload_sound method in src/reachy_mini/daemon/app/routers/media.py without authentication, file-extension checks, content validation, or size validation. The daemon binds to 0.0.0.0 by default and uses permissive CORS allow_origins=["*"], allowing an unauthenticated network attacker to upload arbitrary file types that are written to /tmp/reachy_mini_sounds/<original_filename>. Malicious files can compromise stored-data integrity and can serve as a foothold when combined with other vulnerabilities. This issue is fixed in version 1.8.2.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-55419?

3 open source packages ship an affected version, including reachy-mini.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reachy-mini` | PyPI | All versions | 1.8.2 |
| `reachy-mini` | PyPI | All versions | 1.8.2 |
| `reachy-mini` | PyPI | All versions | 1.8.2 |

## How do I fix CVE-2026-55419?

Upgrade reachy-mini to 1.8.2 or later.

## Is CVE-2026-55419 being exploited?

There is no known exploitation of CVE-2026-55419 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55419 and fix it if it is affected.

What it is: CVE-2026-55419 is a medium-severity vulnerability in pollen-robotics reachy_mini, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55419 in the wild and no public exploit code.

Affected packages and fixed versions:
- reachy-mini (PyPI): affected all versions; fixed in 1.8.2
- reachy-mini (PyPI): affected all versions; fixed in 1.8.2
- reachy-mini (PyPI): affected all versions; fixed in 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55419/ (Markdown: https://insights.sbomify.com/CVE-2026-55419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55419
- OSV: https://osv.dev/vulnerability/CVE-2026-55419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55419/
Summaries are generated and may contain mistakes; the official description above is the record.
