CVE-2026-55420 Discourse: Remote code execution via pdf uploads

High 7.5 Published Updated

Attackers can achieve remote code execution on Discourse servers via malicious PDF uploads when specific non-default configurations are enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55420?

CVE-2026-55420 is a high-severity command injection vulnerability in Discourse Discourse, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, under certain non-default configurations, processing of PDF uploads could be exploited to obtain RCE on the server. This issue is patched in 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

Weakness: CWE-78

Which versions are affected by CVE-2026-55420?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.5, 2026.4.2, 2026.5.1, 2026.7.0

Products include Discourse Discourse.

How do I fix CVE-2026-55420?

Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2, 2026.5.1 or 2026.7.0.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-55420 being exploited?

There is no known exploitation of CVE-2026-55420 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-55420, GHSA-7wq5-jgww-5rw3.

Is CVE-2026-55420 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free