CVE-2026-55427 Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh`
A malicious Coder server can inject arbitrary SSH configuration via unsanitized values, potentially leading to code execution on the developer's machine.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55427?
CVE-2026-55427 is a high-severity command injection vulnerability in coder, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, `coder config-ssh` wrote server-supplied SSH settings (`HostnameSuffix`, `SSHConfigOptions`) into the user's `~/.ssh/config` without sanitizing embedded newlines or restricting directives so a malicious or compromised Coder server could inject arbitrary SSH configuration. Practical exploitation requires control of the server-supplied values through a malicious or compromised deployment, a man-in-the-middle position or admin access to the `HostnameSuffix` and `SSHConfigOptions` settings. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 validates `HostnameSuffix` and `SSHConfigOptions` against a strict character set that rejects newlines and other control characters. As a workaround, inspect `coder config-ssh --dry-run` output before applying changes.
Which versions are affected by CVE-2026-55427?
10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
4 more packages
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder Go | All versions | None |
Products include Coder Coder.
How do I fix CVE-2026-55427?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-55427 being exploited?
There is no known exploitation of CVE-2026-55427 in the wild and no public exploit code.
Other vulnerabilities in coder
- CVE-2026-46354 Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft
- CVE-2026-55429 Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID
- CVE-2026-55428 Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
- CVE-2024-27918 Coder's OIDC authentication allows email with partially matching domain to register
- CVE-2026-44454 Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent
Sources
Also known as GHSA-mcqq-fqgf-rxwm, GO-2026-5913.