CVE-2026-55429 Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID
Attackers with template author or provisioner access can rebind agents across workspaces by manipulating app IDs, bypassing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55429?
CVE-2026-55429 is a high-severity missing authorization vulnerability in coder, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, `UpsertWorkspaceApp` overwrites an existing app's `agent_id` on a primary-key conflict and `insertAgentApp` accepts the app ID from the provisioner's `CompleteJob` payload without verifying it belongs to the workspace being built. `CompleteJob` runs under `dbauthz.AsProvisionerd` so the authorization layer does not block the cross-workspace upsert. Exploitation requires elevated access as a template author or external provisioner operator. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 verifies that any existing `workspace_apps` row matching the supplied ID belongs to the workspace being built and rejects cross-workspace agent reassignment. No known workarounds are available.
Weakness: CWE-639
Which versions are affected by CVE-2026-55429?
10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
4 more packages
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder Go | All versions | None |
Products include Coder Coder.
How do I fix CVE-2026-55429?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55429 being exploited?
There is no known exploitation of CVE-2026-55429 in the wild and no public exploit code.
Other vulnerabilities in coder
- CVE-2026-46354 Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft
- CVE-2026-55427 Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh`
- CVE-2026-55428 Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
- CVE-2024-27918 Coder's OIDC authentication allows email with partially matching domain to register
- CVE-2026-44454 Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent
Sources
Also known as GHSA-9rjw-3gwp-f59v, GO-2026-5909.