CVE-2026-55433 Coder: Devcontainer recreate endpoint missing write authorization allows read-only roles to destroy containers
Low-privilege users can destroy development containers due to missing write authorization checks on the recreate endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55433?
CVE-2026-55433 is a medium-severity missing authorization vulnerability in coder, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, the devcontainer recreate endpoint relied on route middleware that checked only `ActionRead` on the workspace and, unlike the sibling delete endpoint, performed no `ActionUpdate` check before triggering the destructive rebuild. Exploitation requires an existing low-privilege role with access to the target workspace. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 adds an explicit `ActionUpdate` authorization check before the agent is dialed like the delete endpoint. No known workarounds are available.
Weakness: CWE-862
Which versions are affected by CVE-2026-55433?
10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | All versions | 2.29.17 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.32.7 |
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
4 more packages
github.com/coder/coder/v2 Go | From 2.33.0 | 2.33.8 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder/v2 Go | From 2.34.0 | 2.34.2 |
github.com/coder/coder Go | All versions | None |
Products include Coder Coder.
How do I fix CVE-2026-55433?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55433 being exploited?
There is no known exploitation of CVE-2026-55433 in the wild and no public exploit code.
Other vulnerabilities in coder
- CVE-2026-46354 Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft
- CVE-2026-55429 Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID
- CVE-2026-55427 Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh`
- CVE-2026-55428 Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
- CVE-2024-27918 Coder's OIDC authentication allows email with partially matching domain to register
Sources
Also known as GHSA-jqj2-x4c5-jfxm, GO-2026-5922.