CVE-2026-55435 Suspended Coder users retain access to AI Bridge LLM proxy endpoints

Medium 5.4 Published Updated

Suspended Coder users retain access to AI Bridge LLM proxy endpoints because their API keys are not revoked upon suspension.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55435?

CVE-2026-55435 is a medium-severity authentication bypass vulnerability in coder, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, AI Bridge proxy endpoints authenticate via `Server.IsAuthorized` in `coderd/aibridgedserver`, which validates key format, expiry, secret and deleted or system users but does not check whether the account is suspended. Because suspension does not revoke existing API keys, a suspended user's unexpired token keeps working. Practical impact is limited to already-issued API keys of suspended users until those keys are deleted. Versions 2.32.7, 2.33.8, and 2.34.2 patch the issue. As a workaround, on suspension, delete the user's API keys via `DELETE /api/v2/users/{user}/keys`.

Weakness: CWE-863

Which versions are affected by CVE-2026-55435?

8 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.

PackageAffectedFixed in
github.com/coder/coder/v2 GoFrom 2.30.02.32.7, 2.33.8, 2.34.2
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
2 more packages
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
github.com/coder/coder GoAll versionsNone

Products include Coder Coder.

How do I fix CVE-2026-55435?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.32.7, 2.33.8 or 2.34.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-55435 being exploited?

There is no known exploitation of CVE-2026-55435 in the wild and no public exploit code.

Sources

Also known as GHSA-wqxv-w64v-5wh6, GO-2026-5925.

Is CVE-2026-55435 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free