CVE-2026-55436 Coder's AI Bridge Proxy skips TLS certificate verification in default configuration

High 7.4 Published Updated

Attackers in a man-in-the-middle position can intercept traffic because the AI Bridge Proxy skips TLS verification by default, exposing sensitive data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55436?

CVE-2026-55436 is a high-severity vulnerability in coder, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, the AI Bridge Proxy (`aibridgeproxyd`) created a goproxy server whose default transport set `InsecureSkipVerify: true` and only assigned a secure transport when an upstream proxy was configured. In the default configuration (no upstream proxy), outbound HTTPS to the Coder access URL accepted any TLS certificate. Practical exploitation requires an on-path (man-in-the-middle) position between the AI Bridge Proxy and the Coder server. Deployments where they are co-located over loopback are effectively unaffected. The fix in versions 2.32.7, 2.33.8, and 2.34.2 applies the secure transport (TLS 1.2 or higher using system root CAs) unconditionally. As a workaround, ensure the Coder access URL uses a trusted certificate and secure the network path between the AI Bridge Proxy and the Coder server (for example, loopback or mTLS).

Weakness: CWE-295

Which versions are affected by CVE-2026-55436?

8 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.

PackageAffectedFixed in
github.com/coder/coder/v2 GoFrom 2.30.02.32.7, 2.33.8, 2.34.2
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
2 more packages
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
github.com/coder/coder GoAll versionsNone

Products include Coder Coder.

How do I fix CVE-2026-55436?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.32.7, 2.33.8 or 2.34.2.

Is CVE-2026-55436 being exploited?

There is no known exploitation of CVE-2026-55436 in the wild and no public exploit code.

Sources

Also known as GHSA-84rm-42xw-mx52, GO-2026-5920.

Is CVE-2026-55436 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free