CVE-2026-55437 Coder vulnerable to stored HTML injection via workspace agent logs in AgentLogLine component

Medium 5.4 Published Updated

Attackers can inject malicious HTML into workspace agent logs, leading to stored XSS when victims view the dashboard, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-55437?

CVE-2026-55437 is a medium-severity cross-site scripting vulnerability in coder, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.17, 2.32.7, 2.33.8, and 2.34.2, the `AgentLogLine` dashboard component instantiated `ansi-to-html` without `escapeXML: true` and inserted the result via `dangerouslySetInnerHTML` so HTML embedded in workspace agent log lines was rendered as live markup. Server-side sanitization did not neutralize HTML metacharacters. Exploitation requires a victim to view attacker-controlled agent logs in the dashboard. The fix in versions 2.29.17, 2.32.7, 2.33.8, and 2.34.2 enables `escapeXML: true` so HTML metacharacters are escaped before DOM insertion. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2026-55437?

10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.

PackageAffectedFixed in
github.com/coder/coder/v2 GoAll versions2.29.17, 2.32.7, 2.33.8, 2.34.2
github.com/coder/coder/v2 GoAll versions2.29.17
github.com/coder/coder/v2 GoAll versions2.29.17
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.30.02.32.7
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
4 more packages
github.com/coder/coder/v2 GoFrom 2.33.02.33.8
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
github.com/coder/coder/v2 GoFrom 2.34.02.34.2
github.com/coder/coder GoAll versionsNone

Products include Coder Coder.

How do I fix CVE-2026-55437?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-55437 being exploited?

There is no known exploitation of CVE-2026-55437 in the wild and no public exploit code.

Sources

Also known as GHSA-7qw2-f75v-62f7, GO-2026-5919.

Is CVE-2026-55437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free